const regex = /^\s*at\s(?<symbol>[^\r\n\t\f\v (]*?)?(?:\s*)?\(?(?<url>https?:\S+)\:(?<line>\d+):(?<column>\d+)\)?/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*at\\s(?<symbol>[^\\r\\n\\t\\f\\v (]*?)?(?:\\s*)?\\(?(?<url>https?:\\S+)\\:(?<line>\\d+):(?<column>\\d+)\\)?', 'm')
const str = `at (https://s.pinimg.com/mobile/js/pjs-CloseupPage-6b8daa054b87fb85384c.js:1:108083`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}