const regex = /^(?:(?:1?\d{1,2}|2[0-4]\d|25[0-5])\.){3}(1?\d{1,2}|2[0-4]\d|25[0-5])\/(?:[0-9]|[1-2][0-9]|3[0-2])$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:1?\\d{1,2}|2[0-4]\\d|25[0-5])\\.){3}(1?\\d{1,2}|2[0-4]\\d|25[0-5])\\\/(?:[0-9]|[1-2][0-9]|3[0-2])$', 'mg')
const str = `192.168.50.1/16
192.168.50.1/9
92.168.50.1/0
192.168.50.1/
0.0.0.0/0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}