$re = '/^\d{4}\-\d{4}\-\d{2}\-\d{10}$/';
$str = '0000-0000-00-0000000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);