$re = '/\w:\\\\[A-Za-z0-9_.\\\\\s\(\)\/]+\.\w+/';
$str = 'C:\\Windows\\syswow64\\MsiExec.exe -Embedding AA583DDB5809F74DF7508AA445B0C52E E Global\\MSI0000
C:\\Windows\\syswow64\\safa\\dasdsa\\fgasfsaf\\asgsaga\\MsiExec.exe -Embedding AA583DDB5809F74DF7508AA445B0C52E E Global\\MSI0000
"C:\\Program Files (x86)\\Windows Grep\\grep32.exe" -p"C:\\Program Files (x86)\\Site24x7\\WebApp RBM Recorder"
C:\\Program Files (x86)\\Site24x7\\WebApp RBM Recorder';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);