package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:\s|^)\(?(\d+(\.\d+)?p)\)?(\s|$)`)
var str = `(12.2p)
12.2p
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}