#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z0-9 %\-\+:\/]*\b(\d{1,3}\.?\d{0,4})\.?[a-z0-9 \(\)]*out of[a-z ]*(\d{1,3}\.?\d{0,4})\.?.*"
Local $sString = "4 out of 6.0" & @CRLF & _
"2.979 out of 4 gpa" & @CRLF & _
"out of 5" & @CRLF & _
"gpa 3.712 out of 4" & @CRLF & _
"110 out of 110" & @CRLF & _
"4.94 (for second part) out of 6" & @CRLF & _
"9.45 points out of 10 (240 ects)" & @CRLF & _
"5.7 out of 7." & @CRLF & _
"cgpa- 3.66 out of 4" & @CRLF & _
"a-/gpa :3.55 out of 4.00" & @CRLF & _
"4.5 out of a possible 5" & @CRLF & _
"a4 19 out of 22" & @CRLF & _
"1.15 1 being the best grade out of 5" & @CRLF & _
"3.64out of 6" & @CRLF & _
"28 out of 30. final grade 108 out of 110" & @CRLF & _
"2.64out of 4 average 74.02%" & @CRLF & _
"81.77. gpa:3.7out of 4.3" & @CRLF & _
"81.77gpa:3.7 out of 1.3" & @CRLF & _
"cumulative gpa 16.22out of 20.00" & @CRLF & _
"9.13 rank 20 out of 80" & @CRLF & _
"a+/9.65 out of 10" & @CRLF & _
"3.6/4 or 17.87 out of 20" & @CRLF & _
"87.1%/gpa 3.71 out of 5.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")