package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-zA-Z\d:]`)
var str = `badPas$phrase23
goodPassphrase23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}