package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((0?[1-9]|[12][0-9]|3[01])(Jan|JAN|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)([0-9][0-9])|(0?[1-9]|[12][0-9]|30)(Apr|APR|Jun|JUN|Sep|SEP|Nov|NOV)([0-9][0-9])|(0?[1-9]|1[0-9]|2[0-8])(Feb|FEB)([0-9][0-9])|(29)(Feb|FEB)([02468][048]|[13579][26]))$`)
var str = `1Jan18 abcd
1Jan18
01Jan18
31Jan18
31jan18
31jAN18
31JAn18
31JaN18
31JAN18
28Feb18
29Feb18
29Feb20
31Mar18
30Apr18
31Apr18
31May18
30Jun18
31Jun18
31Jul18
31Aug18
30Sep18
31Sep18
31Oct18
30Nov18
31Nov18
31Dec18`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}