re = /[+\-]?[^\w]?(?:0|[1-9]\d*)(?:\.\d*)?(?:[eE][+\-]?\d+)/m
str = 'MAPPED_Baffle_solid_skin_mesh_using_noSavedCoord_absPress_onCover_csvData_Table_1.008000e+04
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end