import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\w+)(\\W+\\1\\b)+";
final String string = "Goodbye bye bye world world world\n"
+ "Sam went went to to to his business\n"
+ "Reya is is the the best player in eye eye game\n"
+ "in inthe\n"
+ "Hello hello Ab aB";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}