re = /[1-9][0-9][0-9]{2}-([0][1-9]|[1][0-2])-([1-2][0-9]|[0][1-9]|[3][0-1])/m
str = '2022-07-11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end