re = /(xcopy)|([A-Z]:\\[^\s\n]*)+/m
str = 'xcopy C:\\test D:\\target\\backup\\files
(xcopy)|([A-Z]:\\\\[^ \\n]*)+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end