#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([Rr]ef|[Cc]loses|[Rr]elated|[Ff]ixes|[Pp]artial)(:|) (#\d+|\w+\#\d+|(https://|)gitlab.com/volterra/.*/issues/\d+))|noref$"
Local $sString = "ref #629" & @CRLF & _
"Ref #629" & @CRLF & _
"ref specification#629" & @CRLF & _
"Ref specification#629" & @CRLF & _
"ref https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Ref https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"ref gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Ref gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"ref: #629" & @CRLF & _
"Ref: #629" & @CRLF & _
"ref: specification#629" & @CRLF & _
"Ref: specification#629" & @CRLF & _
"ref: https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Ref: https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"ref: gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Ref: gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"closes #629" & @CRLF & _
"Closes #629" & @CRLF & _
"closes specification#629" & @CRLF & _
"Closes specification#629" & @CRLF & _
"closes https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Closes https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"closes gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Closes gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"closes: #629" & @CRLF & _
"Closes: #629" & @CRLF & _
"closes: specification#629" & @CRLF & _
"Closes: specification#629" & @CRLF & _
"closes: https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Closes: https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"closes: gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Closes: gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"related #629" & @CRLF & _
"Related #629" & @CRLF & _
"related specification#629" & @CRLF & _
"Related specification#629" & @CRLF & _
"related https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Related https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"related gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Related gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"related: #629" & @CRLF & _
"Related: #629" & @CRLF & _
"related: specification#629" & @CRLF & _
"Related: specification#629" & @CRLF & _
"related: https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Related: https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"related: gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Related: gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"fixes #629" & @CRLF & _
"Fixes #629" & @CRLF & _
"fixes specification#629" & @CRLF & _
"Fixes specification#629" & @CRLF & _
"fixes https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Fixes https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"fixes gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Fixes gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"fixes: #629" & @CRLF & _
"Fixes: #629" & @CRLF & _
"fixes: specification#629" & @CRLF & _
"Fixes: specification#629" & @CRLF & _
"fixes: https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Fixes: https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"fixes: gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Fixes: gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"partial #629" & @CRLF & _
"Partial #629" & @CRLF & _
"partial specification#629" & @CRLF & _
"Partial specification#629" & @CRLF & _
"partial https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Partial https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"partial gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Partial gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"partial: #629" & @CRLF & _
"Partial: #629" & @CRLF & _
"partial: specification#629" & @CRLF & _
"Partial: specification#629" & @CRLF & _
"partial: https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Partial: https://gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"partial: gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"Partial: gitlab.com/volterra/ves.io/specifications/-/issues/629" & @CRLF & _
"noref" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")