import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z.//\\-\\(\\=><) ]+(?<!PRESENT\\b)(?<!ABSENT\\b)(?<!NORMAL\\b)(?<!POSITIVE\\b)(?<!NEGATIVE\\b)(?<!TRACE\\b)) +?(ABSENT|PRESENT|NORMAL|TRACE|POSITIVE|NEGATIVE|\\\"[A-Z]\\\")+? *?([\\(\\+\\) ]*) *?(Absent|Normal|Present|Trace|Positive|Negative)?$";
final String string = "\n"
+ "Deposit : ABSENT\n"
+ "Bile Pigments : Negative NEGATIVE\n"
+ "ABO And RhD Typing : A positive positive\n"
+ "Albumin : Negative NEGATIVE asdasd\n"
+ "Mucus : PRESENT\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}