# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:\s*from\s(?:(?:([^\(\n]*?)\s)|(\[[^\]]*\]))?(?:\((?:(?:((?!HELO|EHLO)[^\s]*)|(?:(?:EHLO)|(?:HELO)))?(?:[\s\w\.]*(?:(?:\[([^\]]*)\])|([^\)\s]*))\))))?(?:\{.*\})?)?
\s*(?:(?:client\s)?[\(\{\[]+([^\)\}\]]*)[\)\}\]]+\;?(?:\{.*\})?)?
(?:[\s\n]*)
(?:\s*(?:by(?:(?:.*?)(?:\;|(?:[\r\n]+))))(?!.*with))?
(?:\s*(?:by\s[^\;]*\)?)(?=.*with)\s*)?
(?:with\s*(?:((?:[^\n;]*))(?:.*\;)?))?
(?:[\s\n]*)?
(?:\(?envelope-from\s*([^\n]*)\;?\)?)?
(?:\s*id[^;]*\;?)?
(?:[\s\n]*)?
(?:for\s([^\;]*)\;)?
(?:[\s\n]*)?
(?:\(.*\)\;)?(?:[\s\n])?
([^\(]+)?
(?:\(?envelope-from\s*([^\n]*)\;?\)?)?
"""
test_str = ("from qzienfhr ([182.109.196.197]) by mail.oucu.edu.eg\n"
" with SMTP (Code-Crafters Ability Mail Server 2012);\n"
" Mon, 03 Dec 2018 12:42:56 +0200")
matches = re.search(regex, test_str, re.MULTILINE | re.VERBOSE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.