$re = '/([0-9]+)(?:st|nd|rd|th)?
/mx';
$str = '151 kent ave
1st ave
1stave
22nd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);