$re = '/^[|[^0-9a-zA-Z\s\'{}:,]|]$/';
$str = '[1m2m3m,2,[]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);