$re = '/^(([0-1][0-9])|([2][0-3])):([0-5][0-9])$/m';
$str = '03:59
01:59
05:59
23:35';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);