$re = '/(?<=\d{2})(\d+)(?=\d{4})/m';
$str = '12987654321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);