package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).ar`)
var str = `The car parked in the garage.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}