import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^\\/{2}(?!\\/).*$";
final String string = "https://docs.asciidoctor.org/asciidoc/latest/comments/\n\n"
+ "ffds\n"
+ "//dfdfds\n"
+ "// kfjdkf lkdsfj lf //\n"
+ "/// not a comment\n"
+ "//// not a comment\n\n"
+ "//\n\n"
+ "// A single-line comment.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}