re = /\s*\-*\d*\s*(\.*|\,*)\d*\s*\+\s*\-*\d*\s*(\.*\,*)\s*\d/m
str = '-343.565+-475845.56565'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end