#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+)\s((\d+)\s(.*)\s?(St|Rd|Ave|Dr|Pl|Sq|Ln))\s?(W|E|N|S)?,\s(.*),\s((\w+)\s(.*))\n"
Local $sString = "1 1067 Niagara Stone Rd, Niagara-On-The-Lake, ON L0S 1J0" & @CRLF & _
"2 4260 Mountainview Rd, Lincoln, ON L0R 1B2" & @CRLF & _
"4 1091 Hutchinson Rd, Haldimand, ON N0A 1K0" & @CRLF & _
"16 3753 Quarry Rd, Lincoln, ON L0R 1B2" & @CRLF & _
"19 131 River Rd, Haldimand, ON N1A 2W3" & @CRLF & _
"20 111 Garrison Village Dr, Niagara-On-The-Lake, ON L0S 1J0" & @CRLF & _
"21 3678 Victoria Ave, Lincoln, ON L0R 2C0" & @CRLF & _
"24 3751 King St, Lincoln, ON L0R 2C0" & @CRLF & _
"34 2878 Holland Rd, Thorold, ON L0S 1E6" & @CRLF & _
"35 103 Overholt Rd, Pelham, ON L0S 1M0" & @CRLF & _
"47 3930 Cherry Ave, Lincoln, ON L0R 1B1" & @CRLF & _
"48 4016 Mountain St, Lincoln, ON L0R 1B7" & @CRLF & _
"49 135 Taylor Rd, Niagara-On-The-Lake, ON L0S 1J0" & @CRLF & _
"50 5943 Sylvia Pl, Niagara Falls, ON L2G 1S9" & @CRLF & _
"51 6863 Lundys Ln, Niagara Falls, ON L2G 1V7" & @CRLF & _
"55 290 John St E, Niagara-On-The-Lake, ON L0S 1J0" & @CRLF & _
"56 5600 King St W, Lincoln, ON L0R 1B3" & @CRLF & _
"63 3900 Cherry Ave, Lincoln, ON L0R 2C0" & @CRLF & _
"64 282 Ridge Rd N, Fort Erie, ON L0S 1N0" & @CRLF & _
"65 4352 Mountainview Rd, Lincoln, ON L0R 1B2" & @CRLF & _
"74 1339 Lakeshore Rd, Niagara-On-The-Lake, ON L0S 1J0" & @CRLF & _
"75 1425 Lakeshore Rd, Niagara-On-The-Lake, ON L0S 1J0" & @CRLF & _
"82 400 Main St W, Grimsby, ON L3M 1T2" & @CRLF & _
"83 3620 Moyer Rd, Lincoln, ON L0R 2C0" & @CRLF & _
"87 1625 Haist St, Pelham, ON L0S 1E0" & @CRLF & _
"91 905 Canborough Rd, Pelham, ON L0S 1C0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")