$re = '/^([0-9]|[1-9][0-9]|100)$/m';
$str = '
1 0
0.1
100
1
25.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);