$re = '/\+\d{1}(?:.\d{3}.)\d{3}-\d{4}/';
$str = '+7(333)333-4444';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);