$re = '/(\()?\d{3}(?(1)\)|-)\d{5}/';
$str = '(123)12345
123-23456
123)12345
(123-12345
12345-
12345-2222
12345--2222
java 似乎不支持 回溯条件查找
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);