import Foundation
let pattern = #"^(\w* \w*)_(\d{8})_(NOZ\d{7})_(\d{2}.\d{2}.\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hans Wurst_12345678_NOZ1234567_24.04.2018"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)