using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(?!.*(?:_dev|_pre|_prod|_test|_)$)[\w-]{1,64}$";
string input = @"!min0db_dev1
min0db_dev_dev
min0db_
_dev
_
min0db_dev1
min0db
min0_devdb
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}