import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^CN=)(.*?)(?=\\s?,\\s?o)";
final String string = "CN= John Q. Public, O=Agency, C=US\n"
+ "CN= John Q. Public, Jr.,O=Agency, C=US\n"
+ "CN=John Q. Public,O=Agency, C=US\n"
+ "CN=John Q. Pu,blic,O=Agency, C=US\n"
+ "CN=some name,ou=Groups,ou=AAA,ou=DCCOMICS,o=boo berries,c=US\n"
+ "CN=some name, ou=Groups,ou=AAA,ou=DCCOMICS,o=boo berries,c=US\n"
+ "CN=some name-Y- , ou=Groups,ou=AAA,ou=DCCOMICS,o=boo berries,c=US\n"
+ "cn= some name-Y-,ou=Groups,ou=AAA,ou=DCCOMICS,o=boo berries,c=US\n"
+ "cn= some na, o me-Y-,ou=Groups,ou=AAA,ou=DCCOMICS,o=boo berries,c=US\n\n"
+ "(?<=^CN=) - positive lookahead to find string starts with CN= and discard that match\n"
+ "(.*?) - non greedy seach for any single character\n"
+ "(?=,\\s?ou\\s=|,\\s?o\\s?=)\n\n\n"
+ "(?=,\\s?ou\\s=|,\\s?o\\s?=)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}