package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[1-9]\d{7}((0\d)|(1[0-2]))(([0|1|2]\d)|3[0-1])\d{3}$`)
var str = `zhuzhi.asf@mail.us`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}