re = /(xcopy)|([A-Z]:\\[^ ]*)+/m
str = 'xcopy C:\\test D:\\target\\backup\\files
(xcopy)|([A-Z]:\\\\[^ ]*)+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end