re = /([0-9]{2}[\.]?[0-9]{3}[\.]?[0-9]{3}[\/]?[0-9]{4}[-]?[0-9]{2})|([0-9]{3}[\.]?[0-9]{3}[\.]?[0-9]{3}[-]?[0-9]{2})/m
str = 'CPF 11111111111
CNPJ11.111.111/0001-11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end