re = /(build|ci|docs|feat|fix|perf|refactor|style|test|chore|revert)\([\w\-]+\):\s.*/m
str = 'Merge branch \'bla\' of askfajl into aslfjkasld'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end