$re = '/amu\.edu\.pl/m';
$str = 'jassem@amu.edu.pl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);