package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\/)([\w\/\[\]\{\}]*)(\??[\w\/\[\]\{\}]+\=[\w\/\[\]\{\}]+)*(\&?[\w\/\[\]\{\}]+\=[\w\/\[\]\{\}]+)*$`)
var str = `/foo/bar/baz/{id}/8/7?querytest=9&abc=234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}