import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\t]*(?>etaLearnW_enabled)[ \\t]?=[ \\t]?(?<etaLearnW_enabled>[01])[ \\t]*[ \\t]*;?";
final String string = "%% LEARNING RATES and other HYPER PARAMETERS\n"
+ " lambdaInfomaxTerm = 1; %coeff before logdetT'T, 0 or 1\n"
+ " \n"
+ " etaLearnW_enabled = 1;\n"
+ "etaLearnW_enabled = 1;\n"
+ "% etaLearnW_enabled = 1;\n"
+ " %etaLearnW_enabled = 1;\n"
+ " etaLearnW = 1E-4;\n\n"
+ " %lambdaRidgeW = 3e-3; %going down, crashes on epoch 3888\n"
+ " lambdaRidgeW = 3e-2;\n"
+ " \n"
+ " etaLearnK_enabled = 1;\n"
+ " etaLearnK = 4E-5; \n"
+ " \n"
+ " %PostSlim:\n"
+ " %lambdaRidgeK = 3e-5; %too weak (going down fast)\n"
+ " %lambdaRidgeK = 3e-4; %too weak (fails at #14628)\n\n"
+ " lambdaRidgeK = 1e-3;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}