#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^....z$"
Local $sString = "reedz" & @CRLF & _
"" & @CRLF & _
"#Write a regular expression which would find all words which have exactly 5 letters in them, of which the last letter is a "z"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")