package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|\s)memo`)
var str = `memo
sss memo eew
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}