$re = '/^[a-z0-9]{5,12}$/i';
$str = 'Shakiljdjj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);