$re = '/^((([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$/m';
$str = 'MMMMDDYY
MDYY
YYYYDDMM
MDYY
DDDDDYYYMM
OODDYYMM
YYDDMMPPPP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);