# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:#JSGF) (?<version>V1.0) (?<encoding>[A-Z-0-9]+) (?<locale>[a-z]{2}-[A-Z]{2});$"
test_str = ("#JSGF V1.0 UTF-8 hu-HU;\n"
"grammar planmaster.hu;\n"
"<command_change_odontogram> = ( <change_to> [ a ] <odontogram_mode> [ felvételére | felvételre ] ) | ( <odontogram_mode> felvétele ) ;\n"
"<change_to> = ( váltás | válts | menj | ugrás | ugorj ) ;\n"
"<odontogram_mode> = ( státuszra | státuszhoz | státusz ) {state} | ( kezelés | kezelésre | kezeléshez | lépésekre | lépésekhez ) {treatment} ;\n"
"<command_full_jaw> = <all> * ( alsó {lower} | felső {upper} ) [ fogsor | állkapocs | fogak | fog ] <all> * <status> ;\n"
"<all> = mind | összes | teljes ;\n"
"<status> = ( <status1> | <status2> | <status3> ) {status} ;\n"
"<status1> = ( ép | alaphelyzet | alaphelyzetbe ) {1} ;\n"
"<status2> = ( hiány | hiányzik ) {2} ;\n"
"<status3> = [ szekunder ] ( szuvas | szuvasodott | szuvasodás ) {3} ;\n"
"<tooth18> = ( 18as | 18-as | tizennyolcas | nyolcas | ( 18 as ) ) {18} ;\n"
"<tooth17> = ( 17es | 17-es | tizenhetes | hetes | ( 17 es ) ) {17} ;\n"
"<tooth16> = ( 16os | 16-os | tizenhatos | hatos ) {16} ;\n"
"<tooth_region> = ( bal {left} | jobb {right} ) ( felső {upper} | alsó {lower} ) ;\n"
"<tooth_number> = ( <tooth18> | <tooth17> | <tooth16> | és ) ;\n"
"<command_select> = ( ( <tooth_number> + ) | <tooth_region> <tooth_number> + ) [ fog | fogak ] ;\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.