package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[?].*[=].+[/].+$`)
var str = `glossary.ua/catalog/ukhod_za_litsom/?PAGEN_1=2/4556
glossary.ua/catalog/ukhod_za_litsom/?PAGEN_1=2
glossary.ua/catalog/ukhod_za_litsom/?PAGEN_1=2/
glossary.ua/catalog//ukhod_za_litsom/?
[?]$
[?].*[/].`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}