import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\bsubject\\b)(?=.([\\s\\S]*)urgent)(?=.([\\s\\S]*)yahoo\\.com).*$";
final String string = "User-Agent: Microsoft-MacOutlook/10.17.1.190326\n"
+ "Date: Wed, 05 Jun 2019 15:04:21 +0800\n"
+ "Subject: FW: DR OKE DANLDAI PLEASEURGENT\n"
+ "From: Dennis Chng <Dennischng@r-logic.com>\n"
+ "To: helpdesk <helpdesk@iqon-asia.com>,\n"
+ " Raynor Tan <raynor@iqon-asia.com>\n"
+ "Message-ID: <IQON.6059aba563.EF09158E-9BED-4A49-AE31-6851E971014F@r-logic.com>\n"
+ "Thread-Topic: DR OKE DANLDAI PLEASE URGENT\n"
+ "References: <341174902.187389.1559716703368.ref@mail.yahoo.com>\n"
+ " <341174902.187389.1559716703368@mail.yahoo.com>\n"
+ "In-Reply-To: <341174902.187389.1559716703368@mail.yahoo.com>\n"
+ "Mime-version: 1.0";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}