package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^,]+)|(\"[^\"]+\")`)
var str = `79.151.89.210 - - [08/Oct/2018:21:59:59 +0200] "GET /web/smartphone/scripts/onlineBanka-nt.min.js?v=20180912 HTTP/1.1" 200 122582 "-" "Mozilla/5.0 (Linux; Android 5.1.1; LG-H955 Build/LMY47S; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/69.0.3497.100 Mobile Safari/537.36|2|KBM_NATIVO|020302" "-" 15600 0 - - "FA66A7B9D443B2C4111E8F8E36DA44AD.worker37"
ce.73989.48.kbgesdek.8523952889_EX-00028_0760831.PDF
ce.74106.48.kbgesdek.8527118018_EX-00028_0729298.pdf
ce.74844.48.kbgesdek.8527191264_EX-00028_0728038.pdf
ce.74844.48.kbgesdek.8527191264_EX-00028.pdf
#^ce[.]([0-9]+)[.]([0-9]+)[.]([^.]+)[.](.*)
#^ce[.]([0-9]+)[.]([0-9]+)[.]kbgesdek[.]*[.](.*pdf)
^ce[.]([0-9]+)[.]([0-9]+)[.]kbgesdek[.]([0-9]{10}_EX-[0-9]{5}_[0-9]{7})[.](pdf)
^ce[.]([0-9]+)[.]([0-9]+)[.]kbgesdek[.]([0-9]{10}_EX-[0-9]{5}_[0-9]{7})[.]([pP][dD][fF])
^ce[.]([0-9]+)[.]([0-9]+)[.]kbgesdek[.]([0-9]{10}_EX-[0-9]{1,5}_[0-9]{1,7})[.]([pP][dD][fF])
https://regex101.com/r/XX6Jra/5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}