package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)dsqdsq`)
var str = `dsqdsqfsqfsqfs
fqsfqsfqsfq
dsqdsq`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}