import Foundation
let pattern = #"(^.)|((?<=-).)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"x12-y34-z56"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)