# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((((([1-9][0-9]((0[48])|([13579][26])|([2468][048])))|(([1-9]((0[48])|([13579][26])|([2468][048]))))|(([13579][26])|([2468][048]))|([48]))|(((([13579][26])|([2468][048]))|[48])00))\/2\/(([1-9])|(1[0-9])|([2][0-9])))|(([1-9][0-9]{0,3})\/((([13578]|1[02])\/([1-9]|[12][0-9]|3[01]))|((([469]|11)\/([1-9]|([12][0-9])|(30)))|(2\/(([1-9])|(1[0-9])|([2][0-8]))))))) ((([02468])|([1][02468])|(2[02])):00)"
test_str = ("判断时间的合法性\n"
"PTA作业链接\n"
"https://pintia.cn/problem-sets/1244999401232809984/problems/1245332988779970560\n"
"题目要求链接\n"
"https://images.ptausercontent.com/218e185f-05fe-4a17-be9b-640b21b74373.pdf\n\n\n"
"2015/8/5 2:00\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.