# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/([0-9]+)?|([a-z]+)?\.jpg|jpeg|png|gif)"
test_str = ("http://site234.com/folder/ar.txt\n"
"http://jtem.com/folder/s.zip\n"
"http://site.com/folder/ddr\n"
"http://sit23e1.ru/folder/eff.jpg\n"
"http://spbrecommender.com/folder/karo.gif\n"
"http://site.eu/folder/spb.pdf\n"
"http://site.com/folder/lego.jpeg\n"
"http://sir.fr/folder/some.jpg\n"
"http://site.com/folder/erro.exe\n"
"http://personel.com/folder/1.png")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.