# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9A-F]{2}:){5}[0-9A-F]{2}"
test_str = ("[DHCP IP: (192.168.1.17)] to MAC address 00:50:8D:91:40:A3, Monday, Aug 10,2020 21:06:09\n"
"[DHCP IP: (192.168.1.11)] to MAC address 00:FA:21:46:F0:70, Monday, Aug 10,2020 19:41:28\n"
"[DHCP IP: (192.168.1.14)] to MAC address 8C:79:67:C1:C4:F7, Monday, Aug 10,2020 19:41:12\n"
"[DHCP IP: (192.168.1.7)] to MAC address 00:1C:C0:F0:8A:94, Monday, Aug 10,2020 16:51:41\n"
"[DHCP IP: (192.168.1.17)] to MAC address 00:50:8D:91:40:A3, Monday, Aug 10,2020 15:53:03\n"
"[DHCP IP: (192.168.1.12)] to MAC address 0C:62:A6:E4:60:A6, Monday, Aug 10,2020 15:48:05\n"
"[Dynamic DNS] host name 520techsec.hopto.org registration successful, Monday, Aug 10,2020 14:29:55\n"
"[Dynamic DNS] host name 520techsec.hopto.org registration failure, Monday, Aug 10,2020 14:29:24\n"
"[Dynamic DNS] host name 520techsec.hopto.org registration failure, Monday, Aug 10,2020 14:28:53\n"
"[Dynamic DNS] host name 520techsec.hopto.org registration failure, Monday, Aug 10,2020 14:28:22\n"
"[DHCP IP: (192.168.1.10)] to MAC address 6C:C2:17:1E:B4:B9, Monday, Aug 10,2020 09:51:03\n"
"[DHCP IP: (192.168.1.17)] to MAC address 00:50:8D:91:40:A3, Monday, Aug 10,2020 09:04:50\n"
"[DHCP IP: (192.168.1.11)] to MAC address 00:FA:21:46:F0:70, Monday, Aug 10,2020 08:10:16\n"
"[DHCP IP: (192.168.1.14)] to MAC address 8C:79:67:C1:C4:F7, Monday, Aug 10,2020 08:10:01\n"
"[DHCP IP: (192.168.1.13)] to MAC address 00:16:44:DF:C7:92, Monday, Aug 10,2020 07:11:22\n"
"[DHCP IP: (192.168.1.13)] to MAC address 00:16:44:DF:C7:92, Monday, Aug 10,2020 07:04:23\n"
"[DHCP IP: (192.168.1.7)] to MAC address 00:1C:C0:F0:8A:94, Monday, Aug 10,2020 04:51:42\n"
"[DHCP IP: (192.168.1.17)] to MAC address 00:50:8D:91:40:A3, Monday, Aug 10,2020 03:52:41\n"
"[DHCP IP: (192.168.1.12)] to MAC address 0C:62:A6:E4:60:A6, Monday, Aug 10,2020 03:48:20\n"
"[DHCP IP: (192.168.1.10)] to MAC address 6C:C2:17:1E:B4:B9, Sunday, Aug 09,2020 21:15:05\n"
"[DHCP IP: (192.168.1.17)] to MAC address 00:50:8D:91:40:A3, Sunday, Aug 09,2020 21:06:42\n"
"[DHCP IP: (192.168.1.8)] to MAC address 9C:B6:D0:73:52:AB, Sunday, Aug 09,2020 20:53:45\n"
"[DHCP IP: (192.168.1.11)] to MAC address 00:FA:21:46:F0:70, Sunday, Aug 09,2020 20:39:03\n"
"[DHCP IP: (192.168.1.14)] to MAC address 8C:79:67:C1:C4:F7, Sunday, Aug 09,2020 20:38:48\n"
"[DHCP IP: (192.168.1.8)] to MAC address 9C:B6:D0:73:52:AB, Sunday, Aug 09,2020 20:33:15\n"
"[DHCP IP: (192.168.1.7)] to MAC address 00:1C:C0:F0:8A:94, Sunday, Aug 09,2020 16:51:41\n"
"[DHCP IP: (192.168.1.17)] to MAC address 00:50:8D:91:40:A3, Sunday, Aug 09,2020 15:53:06\n"
"[DHCP IP: (192.168.1.12)] to MAC address 0C:62:A6:E4:60:A6, Sunday, Aug 09,2020 15:48:33\n"
"[Dynamic DNS] host name 520techsec.hopto.org registration successful, Sunday, Aug 09,2020 14:28:12\n"
"[Dynamic DNS] host name 520techsec.hopto.org registration failure, Sunday, Aug 09,2020 14:27:41\n"
"[Dynamic DNS] host name 520techsec.hopto.org registration failure, Sunday, Aug 09,2020 14:27:10\n"
"[Dynamic DNS] host name 520techsec.hopto.org registration failure, Sunday, Aug 09,2020 14:26:38\n"
"[DHCP IP: (192.168.1.11)] to MAC address 00:FA:21:46:F0:70, Sunday, Aug 09,2020 09:07:51\n"
"[DHCP IP: (192.168.1.14)] to MAC address 8C:79:67:C1:C4:F7, Sunday, Aug 09,2020 09:07:37\n"
"[DHCP IP: (192.168.1.17)] to MAC address 00:50:8D:91:40:A3, Sunday, Aug 09,2020 09:05:37")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.