$re = '/(<footer><!\[CDATA\[)\s?(<p>)?(.*)(<p>)/mU';
$str = '<?xml version="1.0" encoding="utf-8"?>
<content>
<title />
<meta-description />
<meta-robots />
<heading1 />
<canonical />
<footer><![CDATA[ If American cities were superheroes, Des Moines would be an unassuming Peter Parker. This mild Midwestern city\'s economy could be described as its hidden superpower. It\'s certainly one of Forbes magazine\'s darlings: described as a "Best Place for Business" in 2010, and as one of "America\'s Best Cities for Young Professionals" in 2011.<p>The city is also one of the world\'s insurance capitals, as the home of headquarters or major offices for Blue Cross Blue Shield, Nationwide Mutual Insurance Company, Principal Financial Group, Aviva, EMC Insurance Companies, and the Meredith Corporation.</p><p>When the city is off-duty it rocks just as hard. Although Forbes profiled the city\'s friendliness to young professionals, another demographic enjoys Des Moines just as much: families with children. If you\'re bringing kids with you to the Des Moines area, you\'ll be happy to known the area has held onto its Midwestern values, and has plenty to do if you\'re under 18. Start with the Blank Park Zoo, an extremely popular attraction known for its easy-to-navigate layout and its free camel rides. (Just remember what Aladdin told you about camels....) If your kids are more high-adrenaline than that, keep them enthralled with a visit to Adventureland, Des Moines\' favorite roller coaster park.</p><p>A number of museums keep Des Moines culturally and intellectually engaged. The best-known among locals is probably the Science Center of Iowa. A hit with all age groups, the live demonstrations, traveling exhibits (such as a current exhibit about Mars), and IMAX theater keep families, school groups, and adults coming back for more. The State Capitol is another point of interest, and a great place for kids to learn about government, democracy, and civic engagement.</p><p>If the adults need an evening out on the town, Des Moines has a lively theatre scene just waiting to be explored. Ballet Des Moines, Des Moines Metro Opera, the Ankeny Community Theatre and the Des Moines Community Theatre, and the Repertory Theatre of Iowa all light up their respective stages with acting, singing, and dancing talent.</p><p>Finally, Des Moines is also a shopper\'s delight. Find the bargains at Jordan Creek Town Center and Valley West Mall, or look for something more eclectic in the hip Historic East Village, a newly revitalized area filled with boutiques.</p><p>Beneath the polite Midwestern veneer is a hugely fun, dynamic city. Discover Des Moines, and let New Home Source help.</p> ]]></footer>
</content>';
$subst = "$1 <p>$3</p><p>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;